Email deliverability Issues for some customers
Incident Report for TrueContext
Resolved
Email Destination deliverability is completely operational again. Re-tries will continue automatically over time. If you would like the retry to happen sooner, please manually re-execute any failed email destinations.
Posted Dec 05, 2023 - 16:37 EST
Identified
Some customers are experiencing email destination failures. We have identified the issue and a fix is currently being rolled out. We should see recovery within 15 minutes and complete recovery within 1 hour. We will update with more information as we monitor the fix.

All destinations will re-run automatically as the system recovers.
Posted Dec 05, 2023 - 14:30 EST
This incident affected: Submission Processing and Scheduled Jobs.