Our systems are reporting SSO login functionality has been restored. We will continue monitoring.
Posted May 19, 2025 - 11:42 EDT
Identified
A downstream provider used for single sign-on (SSO) is currently experiencing a service disruption. This may impact access to corporate login functionality in TrueContext across the portal and mobile applications. We will continue to monitor the SSO provider's status and will provide an update as soon as possible. TrueContext log in service is not affected by this disruption.
Posted May 19, 2025 - 11:32 EDT
Investigating
A downstream provider used for single sign-on (SSO) is currently experiencing a service disruption. This may impact access to corporate login functionality in TrueContext across the portal and mobile applications. We will continue to monitor the SSO provider's status and will provide an update as soon as possible. TrueContext log in service is not affected by this disruption.
Posted May 19, 2025 - 11:32 EDT
This incident affected: Admin Console and Mobile App Communications.