Page loading may be delayed

Incident Report for TrueContext

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 16:59 EDT

Monitoring

Response times have returned to normal levels. We will continue to monitor the situation.
Posted Sep 03, 2026 - 16:27 EDT

Investigating

The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Sep 03, 2026 - 16:13 EDT
This incident affected: Admin Console, Form Builder, Mobile App Communications, Customer Feedback Forms, and Public REST API.