Email Service Delays
Incident Report for TrueContext
Resolved
The issue is now resolved.
Posted Oct 17, 2023 - 15:09 EDT
Update
The issue is now resolved.

If you are still experiencing delivery issues with emails from Email Destinations, please check with your IT/MS365 administrator to ensure the emails are not being quarantined.
Posted Oct 17, 2023 - 10:57 EDT
Monitoring
We identified mail delivery issues to email addresses hosted in Microsoft/Office 365 beginning approximately 7:00 AM EDT on Monday, October 16th.

We applied a fix at 7:17 PM EDT on Monday, October 16th and are monitoring the results.

Mail originating from the ProntoForms system may have been flagged and quarantined by customer Outlook environments. We speculate that an update to the default quarantine and spam policies resulted in our mail being erroneously categorized.

Mail that has been delivered but flagged may be found within your quarantined messages. Releasing messages from quarantine will allow these messages to be delivered successfully, as well as subsequent messages from ProntoForms.

Affected customers may contact their Microsoft/Outlook 365 administrator to assist with the process of manually releasing affected mail from quarantine.

Alternatively, customers may choose to re-execute the submissions from affected Email Destinations during the times listed above.
Posted Oct 16, 2023 - 19:42 EDT
Update
Update: We have confirmed mail delivery issues to email addresses hosted in Microsoft/Office 365 beginning approximately 7:00 AM EDT on Monday, October 16th.

Mail originating from the ProntoForms system may be flagged and quarantined by customer Outlook environments. We speculate that an update to the default quarantine and spam policies is resulting in our mail being erroneously categorized.

Mail that has been delivered but flagged may be found within your quarantined messages. Releasing messages from quarantine will allow these messages to be delivered successfully, as well as subsequent messages from ProntoForms.

While we continue to investigate these delivery issues, affected customers may contact their Microsoft/Outlook 365 administrator to assist with the process of manually releasing affected mail from quarantine.
Posted Oct 16, 2023 - 18:19 EDT
Investigating
We have identified delays with our downstream email service provider and are actively investigating. Emails are currently queued and will be sent in a timely manner once we resolve the issue.
Posted Oct 16, 2023 - 15:02 EDT
This incident affected: Submission Processing and Scheduled Jobs.